I don’t mean to pick on anyone in particular but here goes…

Maconomy, which many of you are familiar with, checks which browser you are using and if it is not on their supported list, they don’t let you in. This doesn’t make sense. It would make sense to warn people with unsupported browsers that things might not work right. To disallow access entirely eliminates the possibility that it might work fine!

Maconomy is not alone in this. Bruce Schneier has an article entitled Bank Mandates Insecure Browser where a bank specifies exactly the 1 specific browser that is allowed under their terms of service.

This represents a major misunderstanding of Internet technology. To be successful with your web applications they must be widely accessible. This means you need to chose web developers who can write applications that are widely accessible. Like us! 😉